<!DOCTYPE html><html lang="en-GB"><head><meta charset="UTF-8"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="//gmpg.org/xfn/11" /><link rel="shortcut icon" href="//www.wanderlustchloe.com/wp-content/uploads/2017/04/Favicon-icon.png" type="image/x-icon" /><link rel="apple-touch-icon" sizes="180x180" href="//www.wanderlustchloe.com/wp-content/uploads/2017/04/Favicon-icon.png"><link rel="alternate" type="application/rss+xml" title="Wanderlust Chloe RSS Feed" href="//www.wanderlustchloe.com/feed/" /><link rel="alternate" type="application/atom+xml" title="Wanderlust Chloe Atom Feed" href="//www.wanderlustchloe.com/feed/atom/" /><link rel="pingback" href="//www.wanderlustchloe.com/xmlrpc.php" /> <!--[if lt IE 9]>
	<script src="//www.wanderlustchloe.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]--><link rel="dns-prefetch" href="//bam.nr-data.net"><link rel="dns-prefetch" href="//gstatic.com"><link rel="preload" href="//scripts.mediavine.com/tags/wanderlust-chloe.js" as="script"><title>A Detailed Guide To Visiting Corfe Castle, Dorset (2020)</title><link rel="stylesheet" href="//www.wanderlustchloe.com/wp-content/cache/min/1/e1946c7b338223de6f59f485eada4caa.css" data-minify="1" />    <script>var theChampSharingAjaxUrl = 'https://www.wanderlustchloe.com/wp-admin/admin-ajax.php', heateorSsWhatsappShareAPI = 'web', heateorSsUrlCountFetched = [], heateorSsSharesText = 'Shares', heateorSsShareText = 'Share', theChampPluginIconPath = 'https://www.wanderlustchloe.com/wp-content/plugins/super-socializer/images/logo.png', theChampHorizontalSharingCountEnable = 1, theChampVerticalSharingCountEnable = 0, theChampSharingOffset = -10, theChampCounterOffset = -10, theChampMobileStickySharingEnabled = 0, heateorSsCopyLinkMessage = "Link copied.";
		var heateorSsHorSharingShortUrl = "https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/";var heateorSsVerticalSharingShortUrl = "https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/";</script> <style type="text/css">.the_champ_horizontal_sharing .theChampSharing{color:#fff;border-width:0;border-style:solid;border-color:transparent}.the_champ_horizontal_sharing .theChampTCBackground{color:#666}.the_champ_horizontal_sharing .theChampSharing:hover{border-color:transparent}.the_champ_vertical_sharing .theChampSharing{color:#fff;border-width:0;border-style:solid;border-color:transparent}.the_champ_vertical_sharing .theChampTCBackground{color:#666}.the_champ_vertical_sharing .theChampSharing:hover{border-color:transparent}div.the_champ_horizontal_sharing .the_champ_square_count{display:block}@media screen and (max-width:783px){.the_champ_vertical_sharing{display:none!important}}div.the_champ_sharing_title{text-align:center}ul.the_champ_sharing_ul{width:100%;text-align:center}div.the_champ_horizontal_sharing ul.the_champ_sharing_ul li{float:none!important;display:inline-block}</style><meta name="description" content="Planning a trip to Dorset&#039;s historic castle? Find out all you need to know about visiting Corfe Castle, including how to get there, parking and more."/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="//www.wanderlustchloe.com/visiting-corfe-castle-dorset/" /><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="A Detailed Guide To Visiting Corfe Castle, Dorset (2020)" /><meta property="og:description" content="Planning a trip to Dorset&#039;s historic castle? Find out all you need to know about visiting Corfe Castle, including how to get there, parking and more." /><meta property="og:url" content="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" /><meta property="og:site_name" content="Wanderlust Chloe" /><meta property="article:publisher" content="http://www.facebook.com/wanderlustchloe" /><meta property="article:author" content="https://www.facebook.com/wanderlustchloe/" /><meta property="article:section" content="England" /><meta property="article:published_time" content="2020-02-18T16:22:42+00:00" /><meta property="og:image" content="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26.jpg" /><meta property="og:image:secure_url" content="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26.jpg" /><meta property="og:image:width" content="1200" /><meta property="og:image:height" content="800" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Planning a trip to Dorset&#039;s historic castle? Find out all you need to know about visiting Corfe Castle, including how to get there, parking and more." /><meta name="twitter:title" content="A Detailed Guide To Visiting Corfe Castle, Dorset (2020)" /><meta name="twitter:site" content="@WanderlustChloe" /><meta name="twitter:image" content="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26.jpg" /><meta name="twitter:creator" content="@WanderlustChloe" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":["Person","Organization"],"@id":"https://www.wanderlustchloe.com/#/schema/person/000911351d7384eeaebe393b76f08b49","name":"Chloe Gunning","image":{"@type":"ImageObject","@id":"https://www.wanderlustchloe.com/#personlogo","url":"https://www.wanderlustchloe.com/wp-content/uploads/2018/12/WC_Logo-e1559417685319.png","width":600,"height":225,"caption":"Chloe Gunning"},"logo":{"@id":"https://www.wanderlustchloe.com/#personlogo"},"description":"With a passion for food, fun and adventure, Chloe is the pint-sized Brit behind top travel blog Wanderlust Chloe. From volcano boarding in Nicaragua, to sailing around Sicily and eating her way around Japan, her travels have taken her to some of the most incredible spots on the planet. Her favourite thing about travel blogging? Inspiring others to follow in her footsteps!","sameAs":["https://www.facebook.com/wanderlustchloe/","wanderlustchloe","wanderlustchloe","https://twitter.com/WanderlustChloe","https://www.youtube.com/wanderlustchloe"]},{"@type":"WebSite","@id":"https://www.wanderlustchloe.com/#website","url":"https://www.wanderlustchloe.com/","name":"Wanderlust Chloe","description":"A top UK travel blog for lovers of travel, food, luxury and more","publisher":{"@id":"https://www.wanderlustchloe.com/#/schema/person/000911351d7384eeaebe393b76f08b49"},"potentialAction":{"@type":"SearchAction","target":"https://www.wanderlustchloe.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#primaryimage","url":"https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26.jpg","width":1200,"height":800,"caption":"Corfe Castle"},{"@type":"WebPage","@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#webpage","url":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/","inLanguage":"en-GB","name":"A Detailed Guide To Visiting Corfe Castle, Dorset (2020)","isPartOf":{"@id":"https://www.wanderlustchloe.com/#website"},"primaryImageOfPage":{"@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#primaryimage"},"datePublished":"2020-02-18T16:22:42+00:00","dateModified":"2020-02-18T16:22:42+00:00","description":"Planning a trip to Dorset's historic castle? Find out all you need to know about visiting Corfe Castle, including how to get there, parking and more."},{"@type":"Article","@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#article","isPartOf":{"@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#webpage"},"author":{"@id":"https://www.wanderlustchloe.com/#/schema/person/000911351d7384eeaebe393b76f08b49"},"headline":"A Guide To Visiting Corfe Castle, Dorset, England","datePublished":"2020-02-18T16:22:42+00:00","dateModified":"2020-02-18T16:22:42+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#webpage"},"publisher":{"@id":"https://www.wanderlustchloe.com/#/schema/person/000911351d7384eeaebe393b76f08b49"},"image":{"@id":"https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/#primaryimage"},"articleSection":"England,Europe,UK"}]}</script> <link rel='dns-prefetch' href='//scripts.mediavine.com' /><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel="alternate" type="application/rss+xml" title="Wanderlust Chloe &raquo; Feed" href="//www.wanderlustchloe.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Wanderlust Chloe &raquo; Comments Feed" href="//www.wanderlustchloe.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Wanderlust Chloe &raquo; A Guide To Visiting Corfe Castle, Dorset, England Comments Feed" href="//www.wanderlustchloe.com/visiting-corfe-castle-dorset/feed/" /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='ez-toc-inline-css' type='text/css'>div#ez-toc-container p.ez-toc-title{font-size:120%}div#ez-toc-container p.ez-toc-title{font-weight:500}div#ez-toc-container ul li{font-size:95%}div#ez-toc-container{background:#fff;border:1px solid #ddd}div#ez-toc-container p.ez-toc-title{color:#000}div#ez-toc-container ul.ez-toc-list a{color:#428bca}div#ez-toc-container ul.ez-toc-list a:hover{color:#2a6496}div#ez-toc-container ul.ez-toc-list a:visited{color:#428bca}</style><link rel='stylesheet' id='penci-fonts-css' href='//fonts.googleapis.com/css?family=Raleway%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dlatin%2Ccyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext' type='text/css' media='all' /> <script type='text/javascript' src='//www.wanderlustchloe.com/wp-includes/js/jquery/jquery.js'></script>  <script type='text/javascript' async="async" data-noptimize="1" data-cfasync="false" src='//scripts.mediavine.com/tags/wanderlust-chloe.js'></script> <link rel='https://api.w.org/' href='//www.wanderlustchloe.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="//www.wanderlustchloe.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="//www.wanderlustchloe.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='//www.wanderlustchloe.com/?p=22222' /><style type="text/css">.pinit-hover{opacity:0.8!important;filter:alpha(opacity=80)!important}a.pinit-button{border-bottom:0!important;box-shadow:none!important;margin-bottom:0!important}a.pinit-button::after{display:none}</style><style>:root{--mv-create-radius:1rem}</style> <script async src="//www.googletagmanager.com/gtag/js?id=UA-24018806-32"></script> <script>var url = '/visiting-corfe-castle-dorset/';
			var loadType = 'frontendLoad';
			
			window.dataLayer = window.dataLayer || [];
			function frbtagnagios(){dataLayer.push(arguments)};
			frbtagnagios('js', new Date());

			frbtagnagios('config', 'UA-24018806-32');
			frbtagnagios('event', loadType, {
				'send_to': ["UA-24018806-32"],
				'event_category': "Wanderlust Chloe",
				'event_label': url,
				'transport_type': 'beacon'
			});</script> <meta name="google-site-verification" content="MMdOsGjw_41pbIgDbgRhMaKqPQ8vSnJSkM68YK55qzw" /><meta name='B-verify' content='2d3d41dc1d6b1e203f5a5658732a2eb3c1334437' /> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','chloega');

  chloega('create', 'UA-53573708-1', 'auto');
  chloega('send', 'pageview');
  setTimeout(
	"chloega('send','event','Profitable Engagement', 'time on page more than 3 minutes')",
	180000
  );
  console.log("Google Analytics Loaded");</script>   <style type="text/css">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</style> <script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/www.wanderlustchloe.com\/wp-content\/uploads\/2018\/12\/WC_Logo.png"
    },
    "url": "https:\/\/www.wanderlustchloe.com\/",
    "name": "Wanderlust Chloe",
    "description": "A top UK travel blog for lovers of travel, food, luxury and more"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Wanderlust Chloe",
    "alternateName": "A top UK travel blog for lovers of travel, food, luxury and more",
    "url": "https:\/\/www.wanderlustchloe.com\/"
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "A Guide To Visiting Corfe Castle, Dorset, England",
    "description": "&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;Some posts on this site contain affiliate links. If you book or buy something through these links, I earn a small commission (at no extra cost to you). Take a look at my privacy policy for more information.Thinking of visiting Corfe Castle? This guide has all the information you could&hellip;",
    "datePublished": "2020-02-18",
    "datemodified": "2020-02-18",
    "mainEntityOfPage": "https:\/\/www.wanderlustchloe.com\/visiting-corfe-castle-dorset\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/www.wanderlustchloe.com\/wp-content\/uploads\/2019\/09\/Dorset-26.jpg",
        "width": 1200,
        "height": 800
    },
    "publisher": {
        "@type": "Organization",
        "name": "Wanderlust Chloe",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/www.wanderlustchloe.com\/wp-content\/uploads\/2018\/12\/WC_Logo.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-ChloeGunning",
        "name": "Chloe Gunning"
    }
}</script><script type="application/ld+json">{
    "@context": "https:\/\/schema.org\/",
    "@type": "BreadcrumbList",
    "itemListElement": [
        {
            "@type": "ListItem",
            "position": 1,
            "item": {
                "@id": "https:\/\/www.wanderlustchloe.com",
                "name": "Home"
            }
        },
        {
            "@type": "ListItem",
            "position": 2,
            "item": {
                "@id": "https:\/\/www.wanderlustchloe.com\/europe\/",
                "name": "Europe"
            }
        },
        {
            "@type": "ListItem",
            "position": 3,
            "item": {
                "@id": "https:\/\/www.wanderlustchloe.com\/europe\/england\/",
                "name": "England"
            }
        },
        {
            "@type": "ListItem",
            "position": 4,
            "item": {
                "@id": "https:\/\/www.wanderlustchloe.com\/visiting-corfe-castle-dorset\/",
                "name": "A Guide To Visiting Corfe Castle, Dorset, England"
            }
        }
    ]
}</script><style>#ulp-s1HxEzejBEM7CYTT .ulp-submit,#ulp-s1HxEzejBEM7CYTT .ulp-submit:visited{border-radius:2px!important;background:#5db0bf;border:1px solid #5db0bf}#ulp-s1HxEzejBEM7CYTT .ulp-submit:hover,#ulp-s1HxEzejBEM7CYTT .ulp-submit:active{border-radius:2px!important;background:#549eac;border:1px solid #549eac}#ulp-s1HxEzejBEM7CYTT,#ulp-s1HxEzejBEM7CYTT .ulp-content{width:490px;height:320px}#ulp-s1HxEzejBEM7CYTT .ulp-input,#ulp-s1HxEzejBEM7CYTT .ulp-input:hover,#ulp-s1HxEzejBEM7CYTT .ulp-input:active,#ulp-s1HxEzejBEM7CYTT .ulp-input:focus,#ulp-s1HxEzejBEM7CYTT .ulp-checkbox{border-width:1px!important;border-radius:2px!important;border-color:#fff;background-color:#ffffff!important;background-color:rgba(255,255,255,1)!important}#ulp-s1HxEzejBEM7CYTT-overlay{background:rgba(66,66,66,.8)}#ulp-layer-219{width:40px;height:20px}#ulp-layer-219,#ulp-layer-219 *{text-align:right;text-shadow:#000 1px 1px 1px;font-family:'arial',arial;font-weight:400;color:#fff;font-size:24px}#ulp-layer-219{border-radius:0;z-index:1000003;text-align:right;padding:0 0;}#ulp-layer-220{width:339px;height:243px}#ulp-layer-220,#ulp-layer-220 *{text-align:left;font-family:'arial',arial;font-weight:400;color:#000;font-size:14px}#ulp-layer-220{border-radius:0;z-index:1000004;text-align:left;padding:0 0;}</style> <script>var ulp_custom_handlers = {};
			var ulp_cookie_value = "1544005468";
			var ulp_onload_popup = "";
			var ulp_onload_mode = "none";
			var ulp_onload_period = "5";
			var ulp_onscroll_popup = "";
			var ulp_onscroll_mode = "none";
			var ulp_onscroll_period = "5";
			var ulp_onexit_popup = "";
			var ulp_onexit_mode = "none";
			var ulp_onexit_period = "5";
			var ulp_onidle_popup = "";
			var ulp_onidle_mode = "none";
			var ulp_onidle_period = "5";
			var ulp_onabd_popup = "";
			var ulp_onabd_mode = "none";
			var ulp_onabd_period = "5";
			var ulp_onload_delay = "5";
			var ulp_onload_close_delay = "0";
			var ulp_onscroll_offset = "600";
			var ulp_onidle_delay = "30";
			var ulp_recaptcha_enable = "off";
			var ulp_content_id = "22222";</script><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript></head><body class="post-template-default single single-post postid-22222 single-format-standard elementor-default"> <a id="close-sidebar-nav" class="header-1"><i class="penci-faicon fa fa-close" ></i></a><nav id="sidebar-nav" class="header-1" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div id="sidebar-nav-logo"> <a href="https://www.wanderlustchloe.com/"><img class="penci-lazy" src="https://www.wanderlustchloe.com/wp-content/themes/soledad/images/penci-holder.png" data-src="//www.wanderlustchloe.com/wp-content/uploads/2018/12/WC_Logo.png" alt="Wanderlust Chloe" /></a></div><ul id="menu-main-menu" class="menu"><li id="menu-item-1240" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1240"><a href="http://www.wanderlustchloe.com/">Home</a></li><li id="menu-item-1048" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1048"><a href="https://www.wanderlustchloe.com/about-wanderlust-chloe/">About Wanderlust Chloe</a></li><li id="menu-item-12523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12523"><a href="https://www.wanderlustchloe.com/destinations/">Destinations</a></li><li id="menu-item-6957" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-6957"><a href="https://www.wanderlustchloe.com/food/">Food</a><ul class="sub-menu"><li id="menu-item-0" class="menu-item-0"><div class="penci-megamenu"><div class="penci-content-megamenu"><div class="penci-mega-latest-posts col-mn-5 mega-row-1"><div class="penci-mega-row penci-mega-7 row-active"><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2018/05/Puttshack-1-585x390.jpg" href="https://www.wanderlustchloe.com/things-to-do-in-shepherds-bush-london/" title="The Very Best Things To Do In Shepherd&#8217;s Bush Right Now"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/things-to-do-in-shepherds-bush-london/" title="The Very Best Things To Do In Shepherd&#8217;s Bush Right Now">The Very Best Things To Do In Shepherd&#8217;s&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-08T15:04:17+00:00">8th January 2020</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Tredwells-1-585x390.jpg" href="https://www.wanderlustchloe.com/tredwells-review-london/" title="Tredwells London – Restaurant Review (2019)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/tredwells-review-london/" title="Tredwells London – Restaurant Review (2019)">Tredwells London – Restaurant Review (2019)</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-02T08:49:39+00:00">2nd December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Valencia-Spain-36-1-585x390.jpg" href="https://www.wanderlustchloe.com/things-to-do-in-valencia-spain/" title="29+ AMAZING Things To Do In Valencia, Spain (2020 Guide)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/things-to-do-in-valencia-spain/" title="29+ AMAZING Things To Do In Valencia, Spain (2020 Guide)">29+ AMAZING Things To Do In Valencia, Spain&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-06T15:07:19+00:00">6th November 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/10/Lake-District-30-585x390.jpg" href="https://www.wanderlustchloe.com/visiting-the-lake-district-without-a-car/" title="Visiting The Lake District Without A Car"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/visiting-the-lake-district-without-a-car/" title="Visiting The Lake District Without A Car">Visiting The Lake District Without A Car</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-29T09:31:26+00:00">29th October 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2017/09/Brighton-6-585x390.jpg" href="https://www.wanderlustchloe.com/brighton-things-to-do/" title="How To Spend The ULTIMATE Weekend In Brighton, England"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/brighton-things-to-do/" title="How To Spend The ULTIMATE Weekend In Brighton, England">How To Spend The ULTIMATE Weekend In Brighton,&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-25T21:29:36+01:00">25th October 2019</time></p></div></div></div></div></div></div></li></ul></li><li id="menu-item-8618" class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-8618"><a href="https://www.wanderlustchloe.com/hotel/">Hotels</a><ul class="sub-menu"><li class="menu-item-0"><div class="penci-megamenu"><div class="penci-content-megamenu"><div class="penci-mega-latest-posts col-mn-5 mega-row-1"><div class="penci-mega-row penci-mega-5 row-active"><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/12/Zermatt-7-585x390.jpg" href="https://www.wanderlustchloe.com/switzerland-itinerary/" title="The Ultimate Switzerland Itinerary (2020)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/switzerland-itinerary/" title="The Ultimate Switzerland Itinerary (2020)">The Ultimate Switzerland Itinerary (2020)</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-06T13:43:23+00:00">6th January 2020</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/10/Trentino-65-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-lake-garda/" title="Where To Stay In Lake Garda, Italy – Hotels For Every Budget"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-lake-garda/" title="Where To Stay In Lake Garda, Italy – Hotels For Every Budget">Where To Stay In Lake Garda, Italy –&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-27T12:59:36+00:00">27th December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2018/12/Bali-honeymoon-hotel-13-585x390.jpg" href="https://www.wanderlustchloe.com/best-hotels-in-seminyak-bali/" title="Best Hotels In Seminyak &#8211; From Budget To Luxury"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/best-hotels-in-seminyak-bali/" title="Best Hotels In Seminyak &#8211; From Budget To Luxury">Best Hotels In Seminyak &#8211; From Budget To&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-03T15:28:04+00:00">3rd December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Valencia-Spain-20-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-valencia-hotels/" title="Where To Stay In Valencia: Hotels For Every Budget"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-valencia-hotels/" title="Where To Stay In Valencia: Hotels For Every Budget">Where To Stay In Valencia: Hotels For Every&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-18T14:35:35+00:00">18th November 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Langkawi-view-1-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-langkawi/" title="Where to Stay in Langkawi for All Budgets (2020 Guide)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-langkawi/" title="Where to Stay in Langkawi for All Budgets (2020 Guide)">Where to Stay in Langkawi for All Budgets&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-05T11:06:39+00:00">5th November 2019</time></p></div></div></div></div></div></div></li></ul></li><li id="menu-item-6014" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6014"><a href="https://www.wanderlustchloe.com/work-with-me/">Work With Me</a></li><li id="menu-item-15302" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15302"><a href="https://www.wanderlustchloe.com/press-and-media/">Press and Media</a></li><li id="menu-item-6015" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6015"><a href="https://www.wanderlustchloe.com/contact/">Contact</a></li></ul></nav><div class="wrapper-boxed header-style-header-1"><div class="penci-header-wrap"><nav id="navigation" class="header-layout-top header-1 menu-style-1" role="navigation" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="container"><div class="button-menu-mobile header-1"><i class="penci-faicon fa fa-bars" ></i></div><ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1240"><a href="http://www.wanderlustchloe.com/">Home</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1048"><a href="https://www.wanderlustchloe.com/about-wanderlust-chloe/">About Wanderlust Chloe</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-12523"><a href="https://www.wanderlustchloe.com/destinations/">Destinations</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-6957"><a href="https://www.wanderlustchloe.com/food/">Food</a><ul class="sub-menu"><li class="menu-item-0"><div class="penci-megamenu"><div class="penci-content-megamenu"><div class="penci-mega-latest-posts col-mn-5 mega-row-1"><div class="penci-mega-row penci-mega-7 row-active"><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2018/05/Puttshack-1-585x390.jpg" href="https://www.wanderlustchloe.com/things-to-do-in-shepherds-bush-london/" title="The Very Best Things To Do In Shepherd&#8217;s Bush Right Now"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/things-to-do-in-shepherds-bush-london/" title="The Very Best Things To Do In Shepherd&#8217;s Bush Right Now">The Very Best Things To Do In Shepherd&#8217;s&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-08T15:04:17+00:00">8th January 2020</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Tredwells-1-585x390.jpg" href="https://www.wanderlustchloe.com/tredwells-review-london/" title="Tredwells London – Restaurant Review (2019)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/tredwells-review-london/" title="Tredwells London – Restaurant Review (2019)">Tredwells London – Restaurant Review (2019)</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-02T08:49:39+00:00">2nd December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Valencia-Spain-36-1-585x390.jpg" href="https://www.wanderlustchloe.com/things-to-do-in-valencia-spain/" title="29+ AMAZING Things To Do In Valencia, Spain (2020 Guide)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/things-to-do-in-valencia-spain/" title="29+ AMAZING Things To Do In Valencia, Spain (2020 Guide)">29+ AMAZING Things To Do In Valencia, Spain&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-06T15:07:19+00:00">6th November 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/10/Lake-District-30-585x390.jpg" href="https://www.wanderlustchloe.com/visiting-the-lake-district-without-a-car/" title="Visiting The Lake District Without A Car"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/visiting-the-lake-district-without-a-car/" title="Visiting The Lake District Without A Car">Visiting The Lake District Without A Car</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-29T09:31:26+00:00">29th October 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/food/restaurant/"> Restaurants </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2017/09/Brighton-6-585x390.jpg" href="https://www.wanderlustchloe.com/brighton-things-to-do/" title="How To Spend The ULTIMATE Weekend In Brighton, England"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/brighton-things-to-do/" title="How To Spend The ULTIMATE Weekend In Brighton, England">How To Spend The ULTIMATE Weekend In Brighton,&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-10-25T21:29:36+01:00">25th October 2019</time></p></div></div></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category penci-mega-menu menu-item-8618"><a href="https://www.wanderlustchloe.com/hotel/">Hotels</a><ul class="sub-menu"><li class="menu-item-0"><div class="penci-megamenu"><div class="penci-content-megamenu"><div class="penci-mega-latest-posts col-mn-5 mega-row-1"><div class="penci-mega-row penci-mega-5 row-active"><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/12/Zermatt-7-585x390.jpg" href="https://www.wanderlustchloe.com/switzerland-itinerary/" title="The Ultimate Switzerland Itinerary (2020)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/switzerland-itinerary/" title="The Ultimate Switzerland Itinerary (2020)">The Ultimate Switzerland Itinerary (2020)</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2020-01-06T13:43:23+00:00">6th January 2020</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/10/Trentino-65-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-lake-garda/" title="Where To Stay In Lake Garda, Italy – Hotels For Every Budget"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-lake-garda/" title="Where To Stay In Lake Garda, Italy – Hotels For Every Budget">Where To Stay In Lake Garda, Italy –&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-27T12:59:36+00:00">27th December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2018/12/Bali-honeymoon-hotel-13-585x390.jpg" href="https://www.wanderlustchloe.com/best-hotels-in-seminyak-bali/" title="Best Hotels In Seminyak &#8211; From Budget To Luxury"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/best-hotels-in-seminyak-bali/" title="Best Hotels In Seminyak &#8211; From Budget To Luxury">Best Hotels In Seminyak &#8211; From Budget To&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-12-03T15:28:04+00:00">3rd December 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Valencia-Spain-20-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-valencia-hotels/" title="Where To Stay In Valencia: Hotels For Every Budget"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-valencia-hotels/" title="Where To Stay In Valencia: Hotels For Every Budget">Where To Stay In Valencia: Hotels For Every&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-18T14:35:35+00:00">18th November 2019</time></p></div></div><div class="penci-mega-post"><div class="penci-mega-thumbnail"> <span class="mega-cat-name"> <a href="https://www.wanderlustchloe.com/hotel/"> Hotel Reviews </a> </span> <a class="penci-image-holder penci-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Langkawi-view-1-585x390.jpg" href="https://www.wanderlustchloe.com/where-to-stay-in-langkawi/" title="Where to Stay in Langkawi for All Budgets (2020 Guide)"> </a></div><div class="penci-mega-meta"><h3 class="post-mega-title"> <a href="https://www.wanderlustchloe.com/where-to-stay-in-langkawi/" title="Where to Stay in Langkawi for All Budgets (2020 Guide)">Where to Stay in Langkawi for All Budgets&#8230;</a></h3><p class="penci-mega-date"><time class="entry-date published" datetime="2019-11-05T11:06:39+00:00">5th November 2019</time></p></div></div></div></div></div></div></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6014"><a href="https://www.wanderlustchloe.com/work-with-me/">Work With Me</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15302"><a href="https://www.wanderlustchloe.com/press-and-media/">Press and Media</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6015"><a href="https://www.wanderlustchloe.com/contact/">Contact</a></li></ul><div id="top-search" class="dfdf"> <a class="search-click"><i class="penci-faicon fa fa-search" ></i></a><div class="show-search"><form role="search" method="get" id="searchform" action="//www.wanderlustchloe.com/"><div> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" /></div></form> <a class="search-click close-search"><i class="penci-faicon fa fa-close" ></i></a></div></div></div></nav><header id="header" class="penci-header-second header-header-1 has-bottom-line" itemscope="itemscope" itemtype="https://schema.org/WPHeader"><div class="inner-header"><div class="container"><div id="logo"> <a href="https://www.wanderlustchloe.com/"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Wanderlust Chloe" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2018/12/WC_Logo.png"/><noscript><img src="//www.wanderlustchloe.com/wp-content/uploads/2018/12/WC_Logo.png" alt="Wanderlust Chloe"/></noscript></a></div><div class="header-slogan"><h2 class="header-slogan-text">A top UK travel blog for lovers of adventure, food, luxury and more</h2></div><div class="header-social"><div class="inner-header-social"> <a href="https://www.facebook.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" ></i></a> <a href="https://twitter.com/WanderlustChloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" ></i></a> <a href="https://www.instagram.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" ></i></a> <a href="https://uk.pinterest.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-pinterest" ></i></a> <a href="https://www.youtube.com/c/wanderlustchloe?sub_confirmation=1" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i></a> <a href="mailto:chloe@wanderlustchloe.com"><i class="penci-faicon fa fa-envelope" ></i></a> <a href="http://www.wanderlustchloe.com/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" ></i></a></div></div></div></div></header></div><div class="container penci-breadcrumb single-breadcrumb"> <span><a class="crumb" href="https://www.wanderlustchloe.com/">Home</a></span><i class="penci-faicon fa fa-angle-right" ></i> <span><a class="crumb" href="https://www.wanderlustchloe.com/europe/">Europe</a></span><i class="penci-faicon fa fa-angle-right" ></i></i><span><a class="crumb" href="https://www.wanderlustchloe.com/europe/england/">England</a></span><i class="penci-faicon fa fa-angle-right" ></i></i> <span>A Guide To Visiting Corfe Castle, Dorset, England</span></div><div class="container container-single container-single-magazine penci_sidebar penci-enable-lightbox"><div id="main"><div class="theiaStickySidebar"><article id="post-22222" class="post type-post status-publish hentry"><div class="header-standard header-classic single-header"><div class="penci-standard-cat"><span class="cat"><a class="penci-cat-name" href="https://www.wanderlustchloe.com/europe/england/" rel="category tag">England</a><a class="penci-cat-name" href="https://www.wanderlustchloe.com/europe/" rel="category tag">Europe</a><a class="penci-cat-name" href="https://www.wanderlustchloe.com/europe/uk/" rel="category tag">UK</a></span></div><h1 class="post-title single-post-title entry-title">A Guide To Visiting Corfe Castle, Dorset, England</h1><div class="penci-hide-tagupdated"> <span class="author-italic author vcard">by <a class="url fn n" href="https://www.wanderlustchloe.com/author/chloe-gunning/">Chloe Gunning</a></span> <time class="entry-date published" datetime="2020-02-18T16:22:42+00:00">18th February 2020</time></div><div class="post-box-meta-single"> <span><time class="entry-date published" datetime="2020-02-18T16:22:42+00:00">18th February 2020</time></span></div></div><div class="post-image"> <a href="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26.jpg" data-rel="penci-gallery-image-content"> <img class="attachment-penci-full-thumb size-penci-full-thumb penci-lazy wp-post-image" src="https://www.wanderlustchloe.com/wp-content/themes/soledad/images/penci2-holder.png" alt="Corfe Castle" data-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-26-1170x780.jpg"> </a></div><div class="post-entry blockquote-style-1"><div class="inner-post-entry entry-content" id="penci-post-entry-inner"><div style='clear: both'></div><div class='the_champ_sharing_container the_champ_horizontal_sharing' super-socializer-data-href="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/"super-socializer-no-counts="1"><div class='the_champ_sharing_title' style="font-weight:bold" ></div><ul class="the_champ_sharing_ul"><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_facebook_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F")'><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_twitter_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=wanderlustchloe&text=A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England&url=https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F")'><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_pinterest_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_whatsapp_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Whatsapp" Title="Whatsapp" class="theChampSharing theChampWhatsappBackground"><a href="https://web.whatsapp.com/send?text=A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F" rel="nofollow noopener" target="_blank"><ss style="display:block" class="theChampSharingSvg theChampWhatsappSvg"></ss></a></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_email_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Email" Title="Email" class="theChampSharing theChampEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F' ), '_blank')"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/', 'A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England', '')" ><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li></ul><div style="clear:both"></div></div><div style='clear: both'></div><br/><p style="font-size:0.8em;font-style:italic;">Some posts on this site contain affiliate links. If you book or buy something through these links, I earn a small commission (at no extra cost to you). Take a look at my <a href="/privacy-policy">privacy policy</a> for more information.</p><input class="jpibfi" type="hidden"><h2>Thinking of visiting Corfe Castle? This guide has all the information you could need to plan a great day out.</h2><p>The county of Dorset is packed with natural wonders and fascinating historical sights. From <a href="https://www.wanderlustchloe.com/visiting-durdle-door-dorset/">Durdle Door</a>’s epic limestone arch, to the charming village of Abbotsbury and the steep cliffs of West Bay, it’s an area packed outstanding natural beauty.<span id="more-22222"></span></p><p>I visited <a href="https://www.wanderlustchloe.com/holiday-in-dorset/">Dorset</a> for the first-time last year and absolutely fell in love with the region. Corfe Castle was a highlight, so I felt it was only right but to share a little more about visiting!</p><div id="attachment_20431" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-20431" class="size-full wp-image-20431" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Weymouth Harbour" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg" ><noscript><img aria-describedby="caption-attachment-20431" class="size-full wp-image-20431" src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg" alt="Weymouth Harbour" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-38.jpg" ></noscript><p id="caption-attachment-20431" class="wp-caption-text">Weymouth Harbour</p></div><h3><strong>What is Corfe Castle? </strong></h3><p>Corfe Castle isn&#8217;t just a castle, it’s also the name of the village it overlooks. As you drive down the small village’s main street, you’ll be amazed by the view. The ruins of the ancient castle stand ominously behind the village, perched on top of a 55m tall hill.</p><p>It’s thought that the first stones were laid over 1,000 years ago. However, the original keep was constructed out of local limestone for William the Conqueror’s son (King Henry I) around the start of the 12<sup>th</sup> century.</p><div id="attachment_22250" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22250" class="size-full wp-image-22250" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Graveyard in Corfe Castle with ruins in the background" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg" ><noscript><img aria-describedby="caption-attachment-22250" class="size-full wp-image-22250" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg" alt="Graveyard in Corfe Castle with ruins in the background" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-18.jpg" ></noscript><p id="caption-attachment-22250" class="wp-caption-text">Graveyard in Corfe Castle with ruins in the background</p></div><p>Around this time most castles were built from earth and timber, so it’s thought that this was a particularly important castle. Throughout history the castle had numerous uses, from being a royal residence and a treasury, to being a military fortress.</p><p>Unfortunately, the castle was ordered to be destroyed after the English Civil War, so while it’s not intact today, the ruins are still pretty special to see! These days the site is run by the National Trust, and has its own visitor centre and tea rooms.</p><div id="attachment_22242" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22242" class="size-full wp-image-22242" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="The ruins of Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg" ><noscript><img aria-describedby="caption-attachment-22242" class="size-full wp-image-22242" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg" alt="The ruins of Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-10.jpg" ></noscript><p id="caption-attachment-22242" class="wp-caption-text">The ruins of Corfe Castle, Dorset</p></div><h3><strong>How should I plan my visit to Corfe Castle?</strong></h3><p>When I visited we chose to park in the village and walk to the castle, as well as wander the pretty streets. It’s a small village, so it won’t take long to do a lap, but it’s well worth it.</p><p>There are pretty thatched cottages with colourful doors and pretty window boxes filled with flowers, traditional tea rooms, an old-fashioned sweet shop and a few pubs. It’s got that feeling of a quintessential English village.</p><div id="attachment_22251" style="width: 550px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-22251" class=" wp-image-22251" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20540%20811'%3E%3C/svg%3E" alt="Exploring Corfe Castle, Dorset" width="540" height="811" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-735x1103.jpg 735w" data-lazy-sizes="(max-width: 540px) 100vw, 540px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg" ><noscript><img aria-describedby="caption-attachment-22251" class=" wp-image-22251" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg" alt="Exploring Corfe Castle, Dorset" width="540" height="811" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19-735x1103.jpg 735w" sizes="(max-width: 540px) 100vw, 540px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-19.jpg" ></noscript><p id="caption-attachment-22251" class="wp-caption-text">Exploring Corfe Castle, Dorset</p></div><p>And then there’s the castle. I’d recommend around 45 minutes at the castle itself. You’ll want a bit of time to walk up the steep hill, then to read some of the information dotted around the site. Once you’ve taken a few photos and enjoyed the impressive views of the area, you can wander back to the entrance and stop off for a nice cuppa!</p><div id="attachment_22241" style="width: 551px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-22241" class=" wp-image-22241" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20541%20812'%3E%3C/svg%3E" alt="Looking out from Corfe Castle, Dorset" width="541" height="812" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-735x1103.jpg 735w" data-lazy-sizes="(max-width: 541px) 100vw, 541px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg" ><noscript><img aria-describedby="caption-attachment-22241" class=" wp-image-22241" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg" alt="Looking out from Corfe Castle, Dorset" width="541" height="812" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9-735x1103.jpg 735w" sizes="(max-width: 541px) 100vw, 541px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-9.jpg" ></noscript><p id="caption-attachment-22241" class="wp-caption-text">Looking out from Corfe Castle, Dorset</p></div><div id="attachment_20424" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-20424" class="size-full wp-image-20424" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Corfe Castle" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg" ><noscript><img aria-describedby="caption-attachment-20424" class="size-full wp-image-20424" src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg" alt="Corfe Castle" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-24.jpg" ></noscript><p id="caption-attachment-20424" class="wp-caption-text">View from Corfe Castle</p></div><h3><strong>How much does it cost to visit Corfe Castle</strong></h3><p>Tickets for Corfe Castle are available at the National Trust tourist information centre at the entrance. The prices vary according to the time of year you visit. As a general rule, peak times coincide with standard school holidays<strong>. </strong><strong>&nbsp;</strong></p><p>Adult tickets to visit Corfe Castle &#8211; £12 (peak) or £11 (off-peak)<br /> Child tickets to visit Corfe Castle &#8211; £6 (peak) or £5.50 (off-peak) – Age 5-17<br /> There are also options for group or family tickets.</p><p>National Trust members are free &#8211; <a href="https://www.nationaltrust.org.uk/join-us">National Trust membership</a> costs £72 per year.</p><div id="attachment_22244" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22244" class="size-full wp-image-22244" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Path up to Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" ><noscript><img aria-describedby="caption-attachment-22244" class="size-full wp-image-22244" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" alt="Path up to Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" ></noscript><p id="caption-attachment-22244" class="wp-caption-text">Path up to Corfe Castle, Dorset</p></div><h3><strong>Corfe Castle visiting times</strong><strong>&nbsp;</strong></h3><p>The castle is open every single day of the year, except Christmas Day, Boxing Day and 7<sup>th</sup> March.</p><p>In general, Corfe Castle’s opening hours are 10am – 4pm, with the last entry at 3.30pm. Occasionally this changes, or they have to close the site due to bad weather.</p><div id="attachment_22237" style="width: 626px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-22237" class=" wp-image-22237" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20616%20925'%3E%3C/svg%3E" alt="Exploring Corfe Castle, Dorset" width="616" height="925" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-735x1103.jpg 735w" data-lazy-sizes="(max-width: 616px) 100vw, 616px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg" ><noscript><img aria-describedby="caption-attachment-22237" class=" wp-image-22237" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg" alt="Exploring Corfe Castle, Dorset" width="616" height="925" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5-735x1103.jpg 735w" sizes="(max-width: 616px) 100vw, 616px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-5.jpg" ></noscript><p id="caption-attachment-22237" class="wp-caption-text">Exploring Corfe Castle, Dorset</p></div><h3><strong>How to get to Corfe Castle</strong><strong>&nbsp;</strong></h3><p>Corfe Castle is located in the south west of England, on the Isle of Purbeck (Dorset), between Wareham and Swanage. You can use this map to navigate the best route for your visit…</p><p><center><iframe src="https://www.google.com/maps/d/u/0/embed?mid=1rl6PchPvViNHqWAs85-jo6YSco-ZOYHI" width="640" height="480"></iframe></center></p><p style="text-align: center;"><em>Corfe Castle map</em></p><h3><strong>Visiting Corfe Castle by car</strong></h3><p>The simplest way to navigate is to use this Corfe Castle postcode: BH20 5EZ. Most people heading to the village will travel along the A351 (between Wareham and Swanage).</p><p>There are several car parks in the village and close to the castle. If you’re visiting in the summer holidays, you might struggle to find a spot as it does get busy! My advice? Go early!</p><p><img class="wp-image-22239 aligncenter" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20608%20913'%3E%3C/svg%3E" alt="Corfe Castle, Dorset" width="608" height="913" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-735x1103.jpg 735w" data-lazy-sizes="(max-width: 608px) 100vw, 608px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg" ><noscript><img class="wp-image-22239 aligncenter" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg" alt="Corfe Castle, Dorset" width="608" height="913" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7-735x1103.jpg 735w" sizes="(max-width: 608px) 100vw, 608px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-7.jpg" ></noscript></p><h4><strong>Corfe Castle parking information </strong></h4><p>When we visited we parked in West Street Car Park (postcode BH20 5HH) – a pay and display car park with 125 spaces, just a short walk from the castle. It cost £3.10 for a 3-hour ticket during peak time.</p><p>Other options include the National Trust car park (free for members) that’s below the castle at Castle View visitor centre. Beware though, this one involves a pretty steep walk uphill!</p><p>There’s another fun option, which is great if you’ve got kids. You can use the park and ride option in the village of Norden, then catch the Swanage Railway steam train to the Corfe Castle Railway Station. You can find out more and check train times and ticket prices <a href="https://www.swanagerailway.co.uk/">here</a>. These don’t run all year round, so definitely check before you travel!</p><p>Most of the car parks we used in Dorset required us to put in our car’s number plate, so make sure you know that off by heart.</p><div id="attachment_22244" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22244" class="size-full wp-image-22244" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Path up to Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" ><noscript><img aria-describedby="caption-attachment-22244" class="size-full wp-image-22244" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" alt="Path up to Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-12.jpg" ></noscript><p id="caption-attachment-22244" class="wp-caption-text">Path up to Corfe Castle, Dorset</p></div><h3><strong>Visiting Corfe Castle by public transport</strong></h3><p>You can also reach Corfe Castle by bus and train. You’ll need to catch the No.40 bus which goes from Poole to Swanage, stopping in Wareham. As a rough guide, it takes 13 minutes from Wareham, 21 minutes from Swanage or 48 minutes from Poole. Alternatively, you can use Swanage Railway as mentioned above.</p><h3><strong>Best time to visit Corfe Castle</strong></h3><p>In terms of weather, the warmest time to visit Corfe Castle is in the summer months. Between July and September, the average temperature is 17 Celsius, but can reach highs of 26 Celsius… although if there’s a heatwave across the south of England, temperatures could be even higher!&nbsp;</p><p>It gets pretty cold in winter, with average temperatures in December January of 5 Celsius. There’s often a bracing wind, especially up on the hill itself, so wrap up warm.</p><p>I’d recommend visiting in June or September as crowds will be reduced out of the school holidays, parking will be easier, and the experience will be more relaxed.</p><div id="attachment_22231" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22231" class="size-full wp-image-22231" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Winter sunset at Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg" ><noscript><img aria-describedby="caption-attachment-22231" class="size-full wp-image-22231" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg" alt="Winter sunset at Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-1-2.jpg" ></noscript><p id="caption-attachment-22231" class="wp-caption-text">Winter sunset at Corfe Castle, Dorset</p></div><h3><strong>Corfe Castle walks</strong></h3><p>If you fancy making more of a day of it, then there are some lovely walks which pass through Corfe Castle. One of the best takes you from Corfe Castle, along The Purbeck Ridgeway to the coast, passing Old Harry Rocks, and venturing on to Swanage. It’s around 9 miles in total, and takes approximately 5 hours 30 mintes. You can find out more about the route <a href="https://www.nationaltrust.org.uk/corfe-castle/trails/the-purbeck-ridgeway---corfe-castle-to-the-coast">here</a>.</p><p>There’s also this route from <a href="https://www.southwestcoastpath.org.uk/walksdb/584/">Corfe Castle to Kimmeridge</a> if you fancy something shorter, but equally as pretty.</p><div id="attachment_22233" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22233" class="size-full wp-image-22233" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Frosty morning at Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg" ><noscript><img aria-describedby="caption-attachment-22233" class="size-full wp-image-22233" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg" alt="Frosty morning at Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-2-2.jpg" ></noscript><p id="caption-attachment-22233" class="wp-caption-text">Frosty morning at Corfe Castle, Dorset</p></div><h3><strong>Where to eat in Corfe Castle</strong></h3><p>Whether you’re looking for a quick snack or some hearty pub grub, there are a handful of great options in the area.</p><h4><strong>Corfe Castle pubs</strong></h4><p><strong>The Greyhound Inn</strong> – One of the most popular pubs in Corfe Castle as it sits directly below the castle. Lots of great reviews for their fish and chips.</p><p><strong>The Fox Inn – </strong>Dating back to the 1500s, this is a historic pub with lots of character and a roaring fire. It’s dog friendly, so a good option if you’re visiting on a walking route. It&#8217;s also renowned for its Sunday roasts.<strong>&nbsp;</strong></p><p><strong>The Castle Inn – </strong>Small pub with lots of character, serving traditional pub classics and local seafood.</p><div id="attachment_22246" style="width: 624px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-22246" class=" wp-image-22246" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20614%20922'%3E%3C/svg%3E" alt="Corfe Castle village and ruins" width="614" height="922" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-735x1103.jpg 735w" data-lazy-sizes="(max-width: 614px) 100vw, 614px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg" ><noscript><img aria-describedby="caption-attachment-22246" class=" wp-image-22246" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg" alt="Corfe Castle village and ruins" width="614" height="922" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14-735x1103.jpg 735w" sizes="(max-width: 614px) 100vw, 614px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-14.jpg" ></noscript><p id="caption-attachment-22246" class="wp-caption-text">Corfe Castle village and ruins</p></div><h4><strong>Other places to eat in Corfe Castle </strong></h4><p><strong>Mortons House Hotel</strong> – The best restaurant in Corfe Castle, offering a fine-dining menu in smart surroundings. Book in advance if you can!<strong>&nbsp;</strong></p><p><strong>Bankes Arms Hotel – </strong>In the centre of the village, this is another option offering standard pub food, from lunchtime baguettes to meaty burgers in the evenings.</p><p><strong>The Pink Goat – </strong>Cute café, perfect for lunch in Corfe Castle. Expect tea, cakes, quiches, soups and more.<strong>&nbsp;</strong></p><p><strong>Corfe Castle Village Bakery – </strong>If you want to grab a pastry or a snack, this is a great option.</p><p><strong>National Trust Tearooms – </strong>Rather overpriced, but it does offer a great view of the castle and serves up a decent cream tea.</p><p><strong>Corfe Castle Model Village Gardens &amp; Café – </strong>If you’re looking for somewhere to sit outside, then this café has a lovely garden area. It’s another easy option for a cup of tea and a slice of cake.</p><div id="attachment_22248" style="width: 593px" class="wp-caption aligncenter"><img aria-describedby="caption-attachment-22248" class=" wp-image-22248" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20583%20876'%3E%3C/svg%3E" alt="Cottages and ruins in Corfe Castle" width="583" height="876" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-735x1103.jpg 735w" data-lazy-sizes="(max-width: 583px) 100vw, 583px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg" ><noscript><img aria-describedby="caption-attachment-22248" class=" wp-image-22248" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg" alt="Cottages and ruins in Corfe Castle" width="583" height="876" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg 800w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-768x1152.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-585x878.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16-735x1103.jpg 735w" sizes="(max-width: 583px) 100vw, 583px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-16.jpg" ></noscript><p id="caption-attachment-22248" class="wp-caption-text">Cottages and ruins in Corfe Castle</p></div><h3><strong>Corfe Castle accommodation options </strong></h3><p>There are plenty of options of places to stay in Dorset. Whether you want to book a holiday cottage, a B&amp;B or book a camping pitch, there are plenty of places to choose from. If you want to find some accommodation near Corfe Castle, these are my top picks…</p><h4><strong>B&amp;Bs and Hotels near Corfe Castle</strong><strong>&nbsp;</strong><strong>&nbsp;</strong></h4><h5><strong><a href="https://www.booking.com/hotel/gb/mortons-house.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Mortons House Hotel</a> </strong></h5><p>Right in the village of Corfe Castle, and only 5-minute walk to the castle, this 16<sup>th</sup> century manor house is a great option. With cosy lounges, a well-respected restaurant and everything you could need on the doorstep, you’ll be very comfortable here. &nbsp;It also includes free parking – something very handy in a tiny village like this one!<strong>&nbsp;</strong></p><p><a class="Button" href="https://www.booking.com/hotel/gb/mortons-house.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Check prices and availability at Mortons House Hotel here</a></p><div id="attachment_22265" style="width: 1290px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22265" class="size-full wp-image-22265" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201280%20853'%3E%3C/svg%3E" alt="Mortons House Hotel, Corfe Castle" width="1280" height="853" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg 1280w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-1024x682.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-735x490.jpg 735w" data-lazy-sizes="(max-width: 1280px) 100vw, 1280px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg" ><noscript><img aria-describedby="caption-attachment-22265" class="size-full wp-image-22265" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg" alt="Mortons House Hotel, Corfe Castle" width="1280" height="853" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg 1280w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-1024x682.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle-735x490.jpg 735w" sizes="(max-width: 1280px) 100vw, 1280px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Mortons-House-Hotel-Corfe-Castle.jpg" ></noscript><p id="caption-attachment-22265" class="wp-caption-text">Mortons House Hotel, Corfe Castle</p></div><h5><strong><a href="https://www.booking.com/hotel/gb/ammonite-bed-amp-breakfast.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Ammonite B&amp;B</a></strong></h5><p>A cosy B&amp;B right in the heart of Corfe Castle, offering a hearty breakfast and free parking. Rooms look comfortable and there are lots of positive reviews.</p><p><a class="Button" href="https://www.booking.com/hotel/gb/ammonite-bed-amp-breakfast.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Check prices and availability at Ammonite here</a></p><h5><strong><a href="https://www.booking.com/hotel/gb/olivers.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Olivers B&amp;B</a></strong></h5><p>Another option if you’re looking for a friendly B&amp;B in Corfe Castle. Olivers is close to the castle and the station, and is another with great reviews.</p><p><a class="Button" href="https://www.booking.com/hotel/gb/olivers.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Check prices and availability at Olivers here</a></p><h4><strong>Corfe Castle cottages and holiday homes </strong><strong>&nbsp;</strong></h4><h5><strong><a href="https://www.booking.com/hotel/gb/the-old-guildhall.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">The Old Guildhall</a></strong></h5><p>This stylish holiday home has three bedrooms, a great garden, BBQ area and is close to the castle and village. &nbsp;</p><p><a class="Button" href="https://www.booking.com/hotel/gb/the-old-guildhall.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Check prices and availability at The Old Guildhall here</a></p><div id="attachment_22266" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22266" class="size-full wp-image-22266" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20900'%3E%3C/svg%3E" alt="The Old Guildhall, Corfe Castle" width="1200" height="900" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-300x225.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-1024x768.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-768x576.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-1170x878.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-585x439.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-320x240.jpg 320w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-480x360.jpg 480w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-720x540.jpg 720w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-735x551.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg" ><noscript><img aria-describedby="caption-attachment-22266" class="size-full wp-image-22266" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg" alt="The Old Guildhall, Corfe Castle" width="1200" height="900" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-300x225.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-1024x768.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-768x576.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-1170x878.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-585x439.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-320x240.jpg 320w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-480x360.jpg 480w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-720x540.jpg 720w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle-735x551.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/The-Old-Guildhall-Corfe-Castle.jpg" ></noscript><p id="caption-attachment-22266" class="wp-caption-text">The Old Guildhall, Corfe Castle</p></div><h5><strong><a href="https://www.booking.com/hotel/gb/tavern-way-corfe-castle.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Tavern Way</a></strong></h5><p>This basic holiday cottage has two bedrooms and is close to everything you could need in the village.</p><p><a class="Button" href="https://www.booking.com/hotel/gb/tavern-way-corfe-castle.en-gb.html?aid=1151050&amp;no_rooms=1&amp;group_adults=1">Check prices and availability at Tavern Way here</a></p><h4><strong>Camping near Corfe Castle</strong><strong>&nbsp;</strong></h4><p>Camping in Dorset is popular in the warmer months of the year. If you want to camp near Corfe Castle, check out <a href="https://www.campingandcaravanningclub.co.uk/campsites/uk/dorset/wareham/corfe-castle-camping-and-caravanning-club-site/">Corfe Castle Camping and Caravanning Club Site</a>, <a href="https://nordenfarm.com/">Norden Farm Campsite</a> and <a href="https://www.woodyhyde.co.uk/">Woodhyde Campsite</a>. &nbsp;</p><div id="attachment_22236" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22236" class="size-full wp-image-22236" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="In the stocks at Corfe Castle, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg" ><noscript><img aria-describedby="caption-attachment-22236" class="size-full wp-image-22236" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg" alt="In the stocks at Corfe Castle, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Corfe-Castle-Dorset-4.jpg" ></noscript><p id="caption-attachment-22236" class="wp-caption-text">In the stocks at Corfe Castle, Dorset</p></div><h3><strong>Other things to do near Corfe Castle</strong></h3><p>After checking out the Corfe castle ruins, there are plenty more places to add to your trip around Dorset. I had a great road trip in the region in the autumn, and would recommend a quick read of <a href="https://www.wanderlustchloe.com/holiday-in-dorset/">this post</a> for some great suggestions.</p><p>From walking along the Jurassic Coast, to exploring pretty villages, gardens and more, here are a few quick ideas to get you started!&nbsp;</p><p><strong>Durdle Door</strong> &#8211; The most famous spot on Dorset’s Jurassic Coast, Durdle Door is an impressive natural limestone archway standing in the sea. Find out more about <a href="https://www.wanderlustchloe.com/visiting-durdle-door-dorset/">visiting Durdle Door</a>.&nbsp;</p><div id="attachment_22189" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-22189" class="size-full wp-image-22189" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Durdle Door Beach, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg" ><noscript><img aria-describedby="caption-attachment-22189" class="size-full wp-image-22189" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg" alt="Durdle Door Beach, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/Durdle-Door-4.jpg" ></noscript><p id="caption-attachment-22189" class="wp-caption-text">Durdle Door Beach, Dorset</p></div><p><strong>Lulworth Cove</strong> – A stunning cove that is almost a perfect circle, best seen from the cliffs on the South West Coast Path.</p><p><strong>West Bay</strong> – Beautiful beach famous for its huge sandstone cliffs, with 140ft sheer drops to the ground below.</p><div id="attachment_20436" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-20436" class="size-full wp-image-20436" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="West Bay, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg" ><noscript><img aria-describedby="caption-attachment-20436" class="size-full wp-image-20436" src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg" alt="West Bay, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-50.jpg" ></noscript><p id="caption-attachment-20436" class="wp-caption-text">West Bay, Dorset</p></div><p><strong>Milton Abbas</strong> – A picture postcard village of white cottages with thatched roofs and perfect green lawns</p><p><strong>Lulworth Castle &#8211; </strong>17th-century mock castle now housing a museum, with lovely gardens open all year round.</p><p><strong>Old Harry Rocks</strong> – Breathtaking views on the walk from Studland Bay to see the chalk standing stones.</p><p><strong>Portland Bill &#8211; </strong>Classic red and white striped lighthouse on the Isle of Portland.</p><div id="attachment_20421" style="width: 1210px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-20421" class="size-full wp-image-20421" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201200%20800'%3E%3C/svg%3E" alt="Old Harry Rocks, Dorset" width="1200" height="800" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-735x490.jpg 735w" data-lazy-sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg" ><noscript><img aria-describedby="caption-attachment-20421" class="size-full wp-image-20421" src="https://www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg" alt="Old Harry Rocks, Dorset" width="1200" height="800" srcset="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg 1200w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-300x200.jpg 300w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-768x512.jpg 768w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-1024x683.jpg 1024w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-1170x780.jpg 1170w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-585x390.jpg 585w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-263x175.jpg 263w, //www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16-735x490.jpg 735w" sizes="(max-width: 1200px) 100vw, 1200px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2019/09/Dorset-16.jpg" ></noscript><p id="caption-attachment-20421" class="wp-caption-text">Old Harry Rocks, Dorset</p></div><p><strong>I hope you’ve found this guide to visiting Corfe Castle helpful! Don&#8217;t miss<a href="https://www.wanderlustchloe.com/visiting-durdle-door-dorset/"> Durdle Door</a> too, and you can find out more about visiting Dorset and what I got up to on my recent trip <a href="https://www.wanderlustchloe.com/holiday-in-dorset/">here</a>.&nbsp;</strong></p><p style="text-align: center;"><strong>Enjoyed this post? Save it for later using one of these pins…</strong></p><p><img class="alignnone wp-image-22260" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20356%20534'%3E%3C/svg%3E" alt="A Guide To Visiting Corfe Castle, Dorset" width="356" height="534" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg 735w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-585x877.jpg 585w" data-lazy-sizes="(max-width: 356px) 100vw, 356px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg" ><noscript><img class="alignnone wp-image-22260" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg" alt="A Guide To Visiting Corfe Castle, Dorset" width="356" height="534" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg 735w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1-585x877.jpg 585w" sizes="(max-width: 356px) 100vw, 356px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-1.jpg" ></noscript> <img class="alignnone wp-image-22261" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20356%20533'%3E%3C/svg%3E" alt="A Guide To Visiting Corfe Castle, Dorset" width="356" height="533" data-lazy-srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg 735w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-585x877.jpg 585w" data-lazy-sizes="(max-width: 356px) 100vw, 356px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg" ><noscript><img class="alignnone wp-image-22261" src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg" alt="A Guide To Visiting Corfe Castle, Dorset" width="356" height="533" srcset="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg 735w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-200x300.jpg 200w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-683x1024.jpg 683w, //www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2-585x877.jpg 585w" sizes="(max-width: 356px) 100vw, 356px" data-jpibfi-post-excerpt="" data-jpibfi-post-url="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/" data-jpibfi-post-title="A Guide To Visiting Corfe Castle, Dorset, England" data-jpibfi-src="//www.wanderlustchloe.com/wp-content/uploads/2020/01/A-Guide-To-Visiting-Corfe-Castle-Dorset-2.jpg" ></noscript></p> <br/><div style='clear: both'></div><div class='the_champ_sharing_container the_champ_horizontal_sharing' super-socializer-data-href="https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/"super-socializer-no-counts="1"><div class='the_champ_sharing_title' style="font-weight:bold" ></div><ul class="the_champ_sharing_ul"><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_facebook_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Facebook" Title="Facebook" class="theChampSharing theChampFacebookBackground" onclick='theChampPopup("https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F")'><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampFacebookSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_twitter_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Twitter" Title="Twitter" class="theChampSharing theChampTwitterBackground" onclick='theChampPopup("http://twitter.com/intent/tweet?via=wanderlustchloe&text=A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England&url=https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F")'><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampTwitterSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_pinterest_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Pinterest" Title="Pinterest" class="theChampSharing theChampPinterestBackground" onclick="javascript:void((function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());"><ss style="display:block;border-radius:999px;" class="theChampSharingSvg theChampPinterestSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_whatsapp_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Whatsapp" Title="Whatsapp" class="theChampSharing theChampWhatsappBackground"><a href="https://web.whatsapp.com/send?text=A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F" rel="nofollow noopener" target="_blank"><ss style="display:block" class="theChampSharingSvg theChampWhatsappSvg"></ss></a></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count the_champ_email_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" alt="Email" Title="Email" class="theChampSharing theChampEmailBackground" onclick="window.open('mailto:?subject=' + decodeURIComponent('A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Fwww.wanderlustchloe.com%2Fvisiting-corfe-castle-dorset%2F' ), '_blank')"><ss style="display:block" class="theChampSharingSvg theChampEmailSvg"></ss></i></li><li class="theChampSharingRound"><ss class="the_champ_square_count">&nbsp;</ss><i style="width:35px;height:35px;border-radius:999px;" title="More" alt="More" class="theChampSharing theChampMoreBackground" onclick="theChampMoreSharingPopup(this, 'https://www.wanderlustchloe.com/visiting-corfe-castle-dorset/', 'A%20Guide%20To%20Visiting%20Corfe%20Castle%2C%20Dorset%2C%20England', '')" ><ss style="display:block" class="theChampSharingSvg theChampMoreSvg"></ss></i></li></ul><div style="clear:both"></div></div><div style='clear: both'></div><div class="penci-single-link-pages"></div></div></div><div class="post-pagination"><div class="prev-post"><div class="prev-post-inner"><div class="prev-post-title"> <span>previous post</span></div> <a href="https://www.wanderlustchloe.com/mauritius-honeymoon-itinerary/"><div class="pagi-text"><h5 class="prev-title">The Perfect Mauritius Honeymoon Itinerary</h5></div> </a></div></div></div><div class="post-related"><div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div><div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-loop="false" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true"><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/11/Valencia-Tourist-Card-1-585x390.jpg" href="https://www.wanderlustchloe.com/valencia-tourist-card-guide/" title="Is The Valencia Tourist Card Worth It? (2020 Guide To Pros And Cons)"> </a><h3><a href="https://www.wanderlustchloe.com/valencia-tourist-card-guide/">Is The Valencia Tourist Card Worth It? (2020...</a></h3></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2019/08/Lithuania-5-1-585x390.jpg" href="https://www.wanderlustchloe.com/places-to-visit-in-lithuania/" title="Best Places To Visit In Lithuania"> </a><h3><a href="https://www.wanderlustchloe.com/places-to-visit-in-lithuania/">Best Places To Visit In Lithuania</a></h3></div><div class="item-related"> <a class="related-thumb penci-image-holder owl-lazy" data-src="https://www.wanderlustchloe.com/wp-content/uploads/2020/01/Cotswolds-1-copy-585x390.jpg" href="https://www.wanderlustchloe.com/moreton-in-marsh-cotswolds/" title="Things To Do In Moreton In Marsh: A Cotswold Motorhome Adventure"> </a><h3><a href="https://www.wanderlustchloe.com/moreton-in-marsh-cotswolds/">Things To Do In Moreton In Marsh: A...</a></h3></div></div></div><div class="post-comments no-comment-yet" id="comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/visiting-corfe-castle-dorset/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="//www.wanderlustchloe.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p><p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p><p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span class="comment-form-cookies-text" for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</span></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='22222' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="13917255fa" /></p><div class="inv-recaptcha-holder"></div><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="32"/></p></form></div></div></article></div></div><div id="sidebar" class="penci-sidebar-right penci-sidebar-content style-1 pcalign-center"><div class="theiaStickySidebar"><aside id="mc4wp_form_widget-3" class="widget widget_mc4wp_form_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">SUBSCRIBE FOR WANDERLUST</span></h4><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-10115" method="post" data-id="10115" data-name="Subscribe For Wanderlust" ><div class="mc4wp-form-fields"><p> <input type="email" name="EMAIL" placeholder="Your email address" required /></p><p> <input type="submit" value="Sign up" /></p></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1582042963" /><input type="hidden" name="_mc4wp_form_id" value="10115" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form></aside><aside id="search-2" class="widget widget_search"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Search</span></h4><form role="search" method="get" id="searchform" action="//www.wanderlustchloe.com/"><div> <input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" /></div></form></aside><aside id="text-23" class="widget widget_text"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">Collaborating with</span></h4><div class="textwidget"><p><center><a href="https://www.wanderlustchloe.com/work-with-me/"><img class="aligncenter size-full wp-image-17039" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20450%20500'%3E%3C/svg%3E" alt="wanderlustchloe-brands" width="450" height="500" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2018/12/wanderlustchloe-brands.jpg" /><noscript><img class="aligncenter size-full wp-image-17039" src="//www.wanderlustchloe.com/wp-content/uploads/2018/12/wanderlustchloe-brands.jpg" alt="wanderlustchloe-brands" width="450" height="500" /></noscript></a></center></p></div></aside><aside id="text-32" class="widget widget_text"><div class="textwidget"><p><center><a href="https://www.wanderlustchloe.com/press-and-media/"><img class="aligncenter size-full wp-image-19362" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20800%20800'%3E%3C/svg%3E" alt="Wanderlust Chloe - Travel Blogger Awards" width="800" height="800" data-lazy-src="//www.wanderlustchloe.com/wp-content/uploads/2019/07/Wanderlust-Chloe-Travel-Blogger-Awards.png" /><noscript><img class="aligncenter size-full wp-image-19362" src="//www.wanderlustchloe.com/wp-content/uploads/2019/07/Wanderlust-Chloe-Travel-Blogger-Awards.png" alt="Wanderlust Chloe - Travel Blogger Awards" width="800" height="800" /></noscript></a></center></p></div></aside><aside id="text-19" class="widget widget_text"><div class="textwidget"><center><div style="width:165px;padding:0px;margin:0px;border:0px;line-height:0px;"><a target="_blank" href="https://www.trips100.co.uk" title="Trips100 - Travel Blogs" rel="nofollow noopener noreferrer"><img style="width:165px;height:110px;border:0px;margin:0px;padding:0px;" title="Trips100 - Travel Blogs" alt="Trips100 - Travel Blogs" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="//www.trips100.co.uk/top/badge-448-1.gif" /><noscript><img style="width:165px;height:110px;border:0px;margin:0px;padding:0px;" title="Trips100 - Travel Blogs" alt="Trips100 - Travel Blogs" src="//www.trips100.co.uk/top/badge-448-1.gif" /></noscript></a><br /><a target="_blank" href="https://www.trips100.co.uk/" title="Trips100" rel="nofollow noopener noreferrer"><img style="width:165px;height:56px;border:0px;margin:0px;padding:0px;" title="Trips100" alt="Trips100" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="//www.trips100.co.uk/top/sponsor.gif" /><noscript><img style="width:165px;height:56px;border:0px;margin:0px;padding:0px;" title="Trips100" alt="Trips100" src="//www.trips100.co.uk/top/sponsor.gif" /></noscript></a></div></center></div></aside></div></div></div><div class="clear-footer"></div><footer id="footer-section" class="penci-footer-social-media penci-lazy" itemscope itemtype="https://schema.org/WPFooter"><div class="container"><div class="footer-socials-section"><ul class="footer-socials"><li><a href="https://www.facebook.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-facebook" ></i><span>Facebook</span></a></li><li><a href="https://twitter.com/WanderlustChloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-twitter" ></i><span>Twitter</span></a></li><li><a href="https://www.instagram.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-instagram" ></i><span>Instagram</span></a></li><li><a href="https://uk.pinterest.com/wanderlustchloe/" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-pinterest" ></i><span>Pinterest</span></a></li><li><a href="https://www.youtube.com/c/wanderlustchloe?sub_confirmation=1" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-youtube-play" ></i><span>Youtube</span></a></li><li><a href="mailto:chloe@wanderlustchloe.com"><i class="penci-faicon fa fa-envelope" ></i><span>Email</span></a></li><li><a href="http://www.wanderlustchloe.com/feed" rel="nofollow" target="_blank"><i class="penci-faicon fa fa-rss" ></i><span>RSS</span></a></li></ul></div><div class="footer-logo-copyright footer-not-logo"><div id="footer-copyright"><p><a href="http://www.wanderlustchloe.com/work-with-me /">Disclaimer</a> © Wanderlust Chloe 2020</p></div><div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="penci-faicon fa fa-angle-up" ></i> <br>Back To Top</span></a></div></div></div></footer></div><div id="fb-root"></div> <script type='text/javascript'>/* <![CDATA[ */ var wpcf7 = {"apiSettings":{"root":"https:\/\/www.wanderlustchloe.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var jpibfi_options = {"hover":{"siteTitle":"Wanderlust Chloe","image_selector":".jpibfi_container img","disabled_classes":"wp-smiley;nopin","enabled_classes":"","min_image_height":0,"min_image_height_small":0,"min_image_width":0,"min_image_width_small":0,"show_on":"[front],[home],[single],[page],[archive],[search],[category]","disable_on":",20009,20010,20012,20013,20014,20015,20016,20018,8275,20696,20672,20697,20699,20700,21518,20986,21744,21745,21924,21930,21931,22408","show_button":"hover","button_margin_bottom":20,"button_margin_top":20,"button_margin_left":20,"button_margin_right":20,"button_position":"top-left","description_option":["post_title"],"transparency_value":0.2,"pin_image":"default","pin_image_button":"rounded-square","pin_image_icon":"circle","pin_image_size":"small","custom_image_url":"","scale_pin_image":false,"pin_linked_url":true,"pinImageHeight":43.2,"pinImageWidth":43.2,"scroll_selector":"","support_srcset":false}}; /* ]]> */</script>   <script type='text/javascript' async defer src='//www.google.com/recaptcha/api.js?onload=renderInvisibleReCaptcha&#038;render=explicit'></script> <script type='text/javascript'>/* <![CDATA[ */ var EasyAzonPro_Localize_Links = {"ajaxAction":"easyazonpro_localize","ajaxUrl":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php"}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var EasyAzonPro_Components_Popovers = {"ajaxUrl":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php","ajaxAction":"easyazon_get_popover_markup","loading":"Loading product data.","placement":"top","template":"<div class=\"popover easyazon-popover\"><div class=\"arrow\"><\/div><h3 class=\"popover-title\"><\/h3><div class=\"popover-content easyazon-popover-content\"><\/div><\/div>","timeout":"750"}; /* ]]> */</script>    <script type='text/javascript'>/* <![CDATA[ */ var ajax_var_more = {"url":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php","nonce":"c2d45938c3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var ajax_var = {"url":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php","nonce":"c2d45938c3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var ajax_var_more = {"url":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php","nonce":"c2d45938c3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"}; /* ]]> */</script>  <script type='text/javascript'>/* <![CDATA[ */ var SOLEDADLOCALIZE = {"url":"https:\/\/www.wanderlustchloe.com\/wp-admin\/admin-ajax.php","nonce":"c2d45938c3","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","login":"Email Address","password":"Password"}; /* ]]> */</script>        <div class="ulp-overlay" id="ulp-s1HxEzejBEM7CYTT-overlay"></div><div class="ulp-window-container" onclick="jQuery('#ulp-s1HxEzejBEM7CYTT-overlay').click();"><div class="ulp-window ulp-window-middle-center" id="ulp-s1HxEzejBEM7CYTT" data-title="Chloe Facebook" data-width="490" data-height="320" data-position="middle-center" data-close="on" data-enter="on" onclick="event.stopPropagation();"><div class="ulp-content"><div class="ulp-layer" id="ulp-layer-219" data-left="450" data-top="-30" data-appearance="slide-down" data-appearance-speed="1000" data-appearance-delay="1000" data-confirmation="off"><a href="#" onclick="return ulp_self_close();">×</a></div><div class="ulp-layer" id="ulp-layer-220" data-left="85" data-top="40" data-appearance="fade-in" data-appearance-speed="1000" data-appearance-delay="200" data-base64="yes" data-confirmation="off">PGlmcmFtZSBzcmM9Imh0dHBzOi8vd3d3LmZhY2Vib29rLmNvbS9wbHVnaW5zL3BhZ2UucGhwP2hyZWY9aHR0cHMlM0ElMkYlMkZ3d3cuZmFjZWJvb2suY29tJTJGd2FuZGVybHVzdGNobG9lJTJGJnRhYnMmd2lkdGg9MzQwJmhlaWdodD0yMTQmc21hbGxfaGVhZGVyPWZhbHNlJmFkYXB0X2NvbnRhaW5lcl93aWR0aD10cnVlJmhpZGVfY292ZXI9ZmFsc2Umc2hvd19mYWNlcGlsZT10cnVlJmFwcElkPTE1NzgzNDk2MTkxMzI0MDUiIHdpZHRoPSIzNDAiIGhlaWdodD0iMjE0IiBzdHlsZT0iYm9yZGVyOm5vbmU7b3ZlcmZsb3c6aGlkZGVuIiBzY3JvbGxpbmc9Im5vIiBmcmFtZWJvcmRlcj0iMCIgYWxsb3dUcmFuc3BhcmVuY3k9InRydWUiIGFsbG93PSJlbmNyeXB0ZWQtbWVkaWEiPjwvaWZyYW1lPg==</div></div></div></div> <script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){return}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){return}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="//www.wanderlustchloe.com/wp-content/plugins/wp-rocket/assets/js/lazyload/12.0/lazyload.min.js"></script> <script src="//www.wanderlustchloe.com/wp-content/cache/min/1/0ba14f634803a211868e91a397c1f3b8.js" data-minify="1" defer></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1582042963 -->